IP Security Forum

Author Topic: Zu starkes Echo bei Anrufen  (Read 11528 times)

Offline airtwist1

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Zu starkes Echo bei Anrufen
« on: Wednesday, 06.09.2006 10:07 »
Hallo alle zusammen,

wir haben sehr starke Echos beim Telefonieren, gibt es Möglichkeiten oder Lösungen das zu minimieren oder am besten ganz wegzulassen?


mfg

Airtwist1
« Last Edit: Wednesday, 06.09.2006 14:49 by admin »

Offline tankwart

  • Sr. Member
  • ****
  • Posts: 165
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #1 on: Thursday, 07.09.2006 11:27 »
Echos sind ein häufiges Phänomen bei VoIP-Verbindungen und liegen meist an Problemen beim VoIP-Provider (dem Gateway zum Festnetz) oder an zu geringer Internetbandbreite am Ziel oder an der Quelle, und / oder zu hohen IP-Latenzzeiten.

Bovor man irgend welche Tricks probiert, sollte man untersuchen, ob die eigene Internetverbindung tatsächlich stabil und dauerhaft ausreicht (vor allem der Upload!). Gerade zu Spitzenzeiten kann man manche Internetprovider komplett vergessen. Wenn im eigenen LAN noch jemand anders heftig Dateien aus dem Internet lädt und der Fouter bzw. die Firewall keine VoIP Priorisisierung beherrscht (bei den meisten Home-Routern trifft das zu), muss man erst mal dieses hausgemachte Problem lösen.

Wenn das alles in Ordnung ist liegt es meistens am VoIP-Provider, sofortige Klarheit gibt ein Versuch mit einem alternativen VoIP Provider.

An Asterisk zu drehen, macht in der Regel keinen Sinn.

Offline airtwist1

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #2 on: Friday, 08.09.2006 15:00 »
Hallo,

das Problem jedoch liegt glaube ich nicht an den ISProvider, denn ich wähle ja über ISDN Raus, und im Internen Netz mit 100 Mbit dürfte das eigenlich ausreichen sein.
Wir haben momentan gar keine SIP Trunk, sondern nur ein Custom Trink via ISDN welches wir benutzen.


mfg
Airtwist1

Offline Goldhamster

  • Sr. Member
  • ****
  • Posts: 178
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #3 on: Friday, 08.09.2006 18:08 »
Also wenn Du eine qualifizierte Antwort haben willst, musst Du auch konkret und ausführlich Dein Problem schildern. Im VoIP-Forum eine Frage nach Echo stellen, und danach erst sagen, dass Du über ISDN telefonierst - Nix für ungut, aber so kann Dir keiner helfen.

Offline airtwist1

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #4 on: Tuesday, 12.09.2006 18:24 »
Sorry meine Schuld,

wir telefonieren nur über ISDN, im Einsatz ist die AVM Fritz CARD PCI passiv Karte. SUSE 9.0. Alle Komponenten sind auf den neuesten Stand.

Bei manchen anrufen funzt das ganze wunderbar, jedoch bei den häufigsten Anrufen (ca. 90 %) ist immer ein Echo zu hören. ab und zu so laut das man
den gegenüber fast nicht versteht.

An was liegt es den generell, das Echos entstehen? An Hardware Software oder einfach am gegenüber?

vielen Dank für die schnelle Info

mfg
Airtwist1
« Last Edit: Wednesday, 13.09.2006 19:51 by admin »

Offline tankwart

  • Sr. Member
  • ****
  • Posts: 165
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #5 on: Tuesday, 12.09.2006 19:34 »
Echo gibt es auch, um nicht zu sagen, vor allem (!), bei analogen oder ISDN-Gesprächen, aber erst durch die sehr viel größere Signalverzögerung bei VoIP fängt das an, störend zu werden.

Eigentliche Ursache für ein Echo, das Du hörst, ist meist die Gegenstelle, deshalb beobachtest Du bei manchen Gesprächen mal mehr, mal weniger Echo.

Da man keine Kontrolle über die Technik am anderen Ende hat, gibt es in TK-Anlagen und in Vermittlungsstellen sog. Echo-Canceller, die durch mathematische Methoden das ankommende Echo dämpfen. Bei passiven ISDN-Karten muss das der Treiber besorgen, und wenn Du in der Datei etc/asterisk/capi.conf nachsiehst, gibt es auch einige Einstellungsmöglichkeiten für Echo-Cancellation.

Bei einer passiven Fritz-Karte muss aber die CPU mithelfen, und wenn Dein Rechner allzu langsam ist, könnte das theoretisch ein Grund sein, warum Echo Cancellation bei Dir nicht funktioniert. Ein prinzipielles Problem mit Asterisk und der FritzCard PCI gibt es jedenfalls nicht, denn wir haben ein darauf basierendes System nach folgender Anleitung: (Installation Suse 10, Asterisk, FritzCard), und Echo-Probleme sind praktisch nicht existent.

Offline airtwist1

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #6 on: Wednesday, 13.09.2006 11:49 »
Hallo Tankwart,

danke für die schnelle Antwort, ich habe einen P4 mit 2,8 ghz und 2 gb ARbeitsspeicher. So sieht meine Capi.conf aus

also ein Teil....

;echosquelch=1   ;_VERY_PRIMITIVE_ echo suppression
echocancel=yes  ;EICON DIVA SERVER (CAPI) echo cancelation (yes=g165)
                 ;(possible values: 'no', 'yes', 'force', 'g164', 'g165')
echocancelold=yes;use facility selector 6 instead of correct 8 (necessary for older eicon drivers)
;echotail=64     ;echo cancel tail setting (default=0 for maximum)
;echocancelnlp=1 ;activate non-linear-processing; this improves echo cancel ratio, but might
                 ;incorporate variable gain in the signal path.
;bridge=yes      ;native bridging (CAPI line interconnect) if available
;callgroup=1     ;PBX call group
;pickupgroup=1   ;PBX pickup group (which call groups are we allowed to pickup)
;language=de     ;set language for this device (overwrites default language)
;disallow=all    ;RTP codec selection (valid with Eicon DIVA Server only)
;allow=all       ;RTP codec selection (valid with Eicon DIVA Server only)
devices=2        ;number of concurrent calls (b-channels) on this controller
                 ;(2 makes sense for single BRI, 30/23 for PRI/T1)


also an einer schwachen Leistung dürfte das nicht liegen


mfg
Airtwist1

Offline tankwart

  • Sr. Member
  • ****
  • Posts: 165
  • Karma: 0
Re: Zu starkes Echo bei Anrufen
« Reply #7 on: Tuesday, 19.09.2006 08:50 »
Die Rechenleistung dürfte tatsächlich kein Problem sein, es sei denn, irgend ein Task verbraucht permanent zu viel Rechenzeit. Prüfe doch mal die CPU-Auslastung im Leerlauf!

Setze außerdem bitte in der Datei capi.conf ein Semikolon vor echocancel=yes, und starte danach Linux komplett neu. Der CAPI-Parameter echocancel gilt sowieso nur für EICON-Karten, und soll bewirken, dass diese Karten ihre Echo-Cancelation onboard machen. Möglicherweise hat das den Nebeneffekt, dass der CAPI-Treiber Deiner FritzCard die Software-Echo-Cancellation abschaltet, was in Deinem Fall aber nicht gewünscht ist.
« Last Edit: Tuesday, 19.09.2006 08:55 by tankwart »