Author Topic: Zenoss 2.0.2 und WMI data collection  (Read 14431 times)

Offline tankwart

  • Sr. Member
  • ****
  • Posts: 165
  • Karma: 0
Zenoss 2.0.2 und WMI data collection
« on: Saturday, 07.07.2007 14:45 »
It took us quite a while to get WMI management to work in Zenoss 2. Problem is, even though you specify an IP address when manually creating a new network device, zenwin seems to use the DNS computer name instead of the IP address to collect Windows management information. If the IP address does not resolve correctly, WMI authentication will fail with strange error messages, such as:

ERROR_SEM_TIMEOUT: The semaphore timeout period has expired. (121)   or

WMI error talking to MYSERVER: com_error(121): DOS code 0x00000079

This problem will most likely occur when managing remote networks via VPN tunnels, that have their own private DNS zones, for example.

As a workaround, go to your DNS server and make static A records and PTR reverse records for each remote Windows device be monitored. If you don´t want to mess up your enterprise DNS server with those foreign zones, it may be more elegant to create a dedicated DNS server that is used exclusively by zenoss. You can easily check the name resolution within zenoss with  by using the Run Commands / DNS forward and DNS reverse menu commands.

Contrary to what has been said in other forums, we found that it is not necessary to specify the domain name or computer name in the zWinUser field. If you have the same username / password combination for all windows boxes, this allows you to inherit these parameters from the /server/windows level, so you don´t need to specify them for each device individually.
« Last Edit: Saturday, 07.07.2007 15:07 by tankwart »

Offline tankwart

  • Sr. Member
  • ****
  • Posts: 165
  • Karma: 0
Re: Zenoss 2.0.2 und WMI data collection
« Reply #1 on: Thursday, 12.07.2007 09:32 »
Another tip for remotely monitoring Windows services via WMI on Windows XP boxes with windows firewall enabled. In order to open the firewall ports for remote WMI management, execute the following command on the XP commandline:

netsh firewall set service RemoteAdmin enable