Author Topic: Broadcast Adresse aus Versehen, kein Zugriff mehr auf Gerät -- Hilfe -- !!!!  (Read 6867 times)

Offline komakid

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Hallo,

hoffe irgendjemand kann mir weiterhelfen, ich habe folgendes Problem:

Haben ein Gerät besorgt das sich IPPower 9258S nennt, damit kann ich wenn der Server am Weekend mal wieder abstürzt extern den Strom wegnehmen und den Server über WakeOnLan wieder starten (ja ich weis brutal aber wie ihr sicher alle wisst gehts oft nicht anders)...

Also ich frohen Mutes starte das Tool das dabei war, nennt sich IPEdit V.4, zack Gerät erkannt, IP vergeben und Test von extern, hoppla das war die IP des Printservers, also schnell geändert und Enter Enter.
Tja und weg war er, ganzes Netzwerk lahm, damn was ist da passiert...

Nach längerem hin und her hab ich dann herausbekommen das die neue IP aufgrund eines Bugs in dem Tool 192.168.3.255 ist.
Also wer jetzt sagt resetten (gibts keine Resetfunktion) über Seriell und Hyperterminal geht auch nichts.

ARP Befehl fügt zwar den Eintrag hinzu aber das Gerät lässt das leider kalt, kein Ping und schon gar kein Webinterface möglich.

Also dachte ich muss Subnetting gehen, eine Adresse mit Subnetmask auf der 192.168.3.255 nicht Broadcastet und ansprechbar ist, aber irgendwie ist das leichter gesagt als getan.

192.168.2.10 mit 255.255.248.0 sollte es tun aber weit gefehlt, keine Chance.

Nächstes Problem ist glaub ich auch das der Router dazwischen ist, da ich kein Crossover Kabel habe,wurde zwar alles deaktiviert an DHCP usw. aber naja....

Also was ich wirklich dringend bräuchte wäre eine gute Lösung für IP und Subnetmask für Router und Client um wieder auf die IPPower zugreifen zu können.

IP ist derzeit 192.168.3.255 Port:80, Subnetmask 255.255.255.0, Gateway 192.168.3.20 und DNS 192.168.3.100

Danke schonmal im Voraus  :)

Gruß aus Wien

Offline tankwart

  • Sr. Member
  • ****
  • Posts: 165
  • Karma: 0
Hallo Komakid,

das ist eine nette Denksportaufgabe.  :)  Was mir nicht ganz klar ist, willst Du das remote lösen (ziemlich aussichtslos) oder geht es Dir darum, vor Ort wieder irgendwie Zugriff auf das IPPower-Teil zu bekommen, um die IP-Adresse zu ändern?

Falls letzteres zutrifft, würde ich mal Supernetting probieren, also einen PC anzuschliessen, dessen Netzmaske z.B. 255.255.0.0 ist, dann wird sich der Client nicht weigern, auf der Class-C Broadcast-Adresse einen Unicast rauszuschicken. Für den IP-Stack der IPPower ist das aber immer noch die Broadcast-Adresse, und ob damit der Webserver anzusprechen ist, kann man nicht vorhersagen. Falls nicht, hilft wohl nur noch ein Factory Reset.

Gruß aus Berlin!
« Last Edit: Monday, 26.02.2007 22:26 by tankwart »

Offline Cheffe

  • Full Member
  • ***
  • Posts: 25
  • Karma: 0
Ich würde mich erst mal Grundlegend mit Netzwerken beschäftigen bevor ich etwas tue von dem ich keine Ahnung habe ;-)

Zum Thema - Warum baust du nicht erst ein Netzwerk mit dem "teil" und einem PC auf? Somit ist schon mal festgelegt dass keine Störfaktoren wie
Printserver und Router vorhanden sind.

Alle Geräte müssen im selben SUBNETZ liegen.

Notfallplan :-)
Wenns noch nichts hilft, bau den Kasten auseinader, hol die PLatine Raus und wickel die mit Alufolie ein. Natürlich ohne Strom drauf.
Der Reset geht immer, es sei denn die Daten werden in ein EProm gebrannt.

Wenns seitens des Herstellers die Erkenntnis eines Bugs gibt, liegt es ja nicht weit von der Hand dass es auch ein Update gibt.

Ansonsten RTFM: ftp://ftp.opengear.com/manual/IP POWER 9258 Quick Start and User Manual.pdf

Offline komakid

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Hallo Tankwart,

Ne Remote geht da gar nichts mehr, ich sitz daneben und versuche das irgendwie wieder hinzukriegen.

Die eheste Chance ist das IpEdit das ding wiederfindet, deshalb auch meine Idee mit subnetting.

Der Hersteller sitzt in Taiwan und auf die Anfragen reagierte bis jetzt leider niemand.

Ich bin mir sicher das es über Hyperterminal irgendeinen Befehl gibt um DHCP wieder zu aktivieren aber kann leider nicht hellsehen :)

So habe Das ding momentan mim Laptop ohne Störfaktoren dazwischen zusammengehängt, aber naja tut sich genausowenig immo wie vorher.


Offline komakid

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Hello,

so hab andere Lösung gefunden,

Auf Garantie verzichtet, zerlegt, EEPROM rausgefischt und mit Willem Programmer neu bespielt mit letztem Bios.

Somit ist alles wieder auf Default und er funktioniert wieder einwandfrei.

Schade das keine "einfacheren" Lösungsvorschläge gekommen sind.

PS: Cheffe spar dir deinen Tastaturverschleiß in Zukunft... wo Noob daneben steht muss kein Noob dahinter sein...

Punkt 1: Wenn eine IP fehlerhaft vergeben wird und diese die Broadcast Adresse des verwendeten Netzes ist, muss definitv nicht jedes Gerät im gleichen Subnetz sein, weil wenn das so leicht funktionieren würde hätte es diesen Post nie gegeben und du hättest ihn nie nur halb gelesen bzw. halb verstanden.

Punkt 2: Selbst wenn es die Erkenntnis eines Bugs auch schon beim Hersteller gibt und er ein Update bzw. eine neue Softwareversion rausbringt wo der Bug beseitigt ist, nützt das Leuten bei denen das Problem schon aufgetreten ist herzlich wenig, was nützt das beste Update wenn man keine Möglichkeiten mehr hat es einzuspielen (siehe Microsoft) "lol"

Punkt 3: Hätte es sich hierbei um einen flüchtigen Speicher gehandelt, reicht es wenn man diesen oder seine Batterie rausnimmt und ein wenig wartet...

PS 2: Alufolie verwende ich nur wenn ich vermeiden will das Aliens meine Gedanken lesen ;)

So Long Greets Koma